fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: (SOLVED) General Configuration, LESS & Styles

SOLVED General Configuration, LESS & Styles 4 years 8 months ago #2447

  • lokoskirtap
  • lokoskirtap's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 4
  • Karma: 1
Hi all, hope you are fine.

I have a problem with changing the style of the quick start package JD Boston. How one can change variables (like @brand-primary and so on) to change all the site?
I am developing locally on linux, so I expected that editing variable.less file and compiling (lessc bootstrap.less ../css/bootstrap.css) would solve the problem, but there is no change at all.

What is the proper template general configuration and way to change less files, so the change will be affected on the remote server later too? How this development/non-development/optimizing/other modes work on back of the site?

I am also not able to change the basic template settings from the administrator panel (exclamation mark shows up).

Thank you for any advice.
Last Edit: 4 years 8 months ago by lokoskirtap.
The administrator has disabled public write access.

General Configuration, LESS & Styles 4 years 8 months ago #2452

  • lokoskirtap
  • lokoskirtap's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 4
  • Karma: 1
Please guys, help me. I reinstalled entire package at least six times and tried like tens of ways to change the style without desired effect... :dry:
The administrator has disabled public write access.

General Configuration, LESS & Styles 4 years 8 months ago #2457

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Hi,

In JD Boston variables are not working. We manually add color in less file. So you can change the color from .less files.

Path: templates/TEMPLATENAME/less

Thanks
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

General Configuration, LESS & Styles 4 years 8 months ago #2458

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Note: Make sure you Enable the Development Mode from the template setting.

www.screencast.com/t/PjeFu9oXOQXI
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

General Configuration, LESS & Styles 4 years 8 months ago #2460

  • lokoskirtap
  • lokoskirtap's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 4
  • Karma: 1
Ok, tell me please what I am doing wrong. There are another t3 stylesheets loaded in this general configuration.

I made the process all over again from the starting point. I have ~

~ installed successfully the quick starter.
~ checked general configuration of the template - it equals yours one.
~ changed less file (brand primary and secondary color)
~ compiled files

No change :-(

I have also tried to replace the t3 template.css file with that template.css file from /templates/jdboston/css/ path before, nothing happened.
Attachments:
The administrator has disabled public write access.

General Configuration, LESS & Styles 4 years 8 months ago #2461

  • lokoskirtap
  • lokoskirtap's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 4
  • Karma: 1
Oh no.. As I can see, you don't use variables in the template.less file. Does it have some reason? :S

Ok, then when I write them to the template.less file, does it affect everywhere these change? (On the remote server and optimized css files too)
The administrator has disabled public write access.

General Configuration, LESS & Styles 4 years 8 months ago #2474

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Hello,

We are never planned to use variables in this template. But yeah for future templates or next update we already got this planted in our heads.

Note: Make sure you Enable the Development Mode from the template setting.
www.screencast.com/t/PjeFu9oXOQXI
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
The following user(s) said Thank You: lokoskirtap

General Configuration, LESS & Styles 4 years 8 months ago #2483

  • lokoskirtap
  • lokoskirtap's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 4
  • Karma: 1
I solved that by changing every occurrence of the blue color in the /templates/jdboston/less/ path to the @brand-primary variable and then with visual studio code editor i have replaced all occurrences in entire package to my color. It sounds complicated but it's the only solution IMHO.
Last Edit: 4 years 8 months ago by lokoskirtap.
The administrator has disabled public write access.
The following user(s) said Thank You: chandandeep
Moderators: chandandeep
Time to create page: 0.426 seconds
Cron Job Starts