fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Installation Pro Version on Joomla V4.0.2

Installation Pro Version on Joomla V4.0.2 2 months 5 days ago #31190

  • ed733
  • ed733's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi LALIT,
on Aug 13th 2020, V1.8 changeLog said : "JOOMLA 4 Compatible".
4 hours ago you've just said the opposite. The problem is that I've paid for JD PRO and the only thing I get is that message when I try to create a new page : "Class 'JObserverMapper' not found".
If it's a new category :" 0 Class 'CategoryHelperAssociation' not found "
Could you please confirm if JDPRO is J4 compatible or not ?
If yes, could you please help me to have JD working on my J4.0.3 brand new site and If not, I'd like you to refund me.
By the way, If I install only astroid framework, everything is fine.
So, my last question is :
If I start building some pages with Astroid, will I lose my work when later installing JDPRO (when really compatible) ?
Thanks for your job and your precise answer.
Edouard
The administrator has disabled public write access.

Installation Pro Version on Joomla V4.0.2 2 months 5 days ago #31192

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Hello,

In the v1.8 release then it's compatible with the beta J4 version. But we are working on it.
Please stay.

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Installation Pro Version on Joomla V4.0.2 2 months 5 days ago #31194

  • ed733
  • ed733's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
" By the way, If I install only astroid framework, everything is fine.
So, my last question is :
If I start building some pages with Astroid, will I lose my work when later installing JDPRO (when really compatible) ? "
Thank for your last answer, could you please answer the above question as I really need to move on ?
Ed
The administrator has disabled public write access.

Installation Pro Version on Joomla V4.0.2 2 months 5 days ago #31196

  • ImageVillage
  • ImageVillage's Avatar
  • Offline
  • Premium Member
  • Posts: 136
  • Thank you received: 8
  • Karma: 0
My advice would be to create your site on the latest J3.10.X that is compatible with JD Builder and then migrate once all the benchmark testing has been done, as of right now the latest version of J4.03 is not stable enough for building on using 3rd party extensions. The framework is very different and as such there will be many many bugs to fix and compatibility issues, but, once everything has been successfuly tested migrating will be a breeze, the latest version of J3 has an upgrade process that will analyse your current config and existing components and tell you what is not compatible, ensuring everything is compatible would a be a far better solution. I had a lengthy conversation with some guys I know at JOOMLART last night about this and it is definitely the right way forward, unfortunately it's too early to be jumping onto Joomla 4 and we need to allow developers a while to catch up and make everything compatible.
If you can be anything in this world, be kind!
Last Edit: 2 months 5 days ago by ImageVillage.
The administrator has disabled public write access.

Installation Pro Version on Joomla V4.0.2 1 month 3 weeks ago #31253

  • ImageVillage
  • ImageVillage's Avatar
  • Offline
  • Premium Member
  • Posts: 136
  • Thank you received: 8
  • Karma: 0
Hey Lalit, can we all get an idea on what is happening with JD Builder and JoomDev? Are we likely to see Joomla 4 updates to templates and JD Builder? Obviously the issue anyone will have is that "if/when" JD Builder becomes J4 compatible they cannot migrate their Joomla installation until their template is also compatible? I understand this is a ton of work to do updating all templates too but surely you guys have been working on this as we have known for the past year that J4 was going into Alpha release?

I just think we could all appreciate some kind of response to this and a realistic timescale for the compatible and "tested" release, we know their will be bugs and it must be an anxious time for you knowing there will be endless reports and issues to deal with and hopefully the community can all help but the whole JoomDev product compatibility/upgrade situation deserves a valid and informative response?

Hope you guys are well.
If you can be anything in this world, be kind!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: chandandeep
Time to create page: 0.386 seconds
Cron Job Starts