fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: Errors on website with the quick starter template

Errors on website with the quick starter template 1 month 3 weeks ago #31254

I am seeing these two issues.

1. After installed the quick starter template I get these errors.
Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/c9sgp3b4y8h6/public_html/libraries/src/User/UserHelper.php on line 636

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/c9sgp3b4y8h6/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 717

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/c9sgp3b4y8h6/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 1768

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/c9sgp3b4y8h6/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 2424

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/c9sgp3b4y8h6/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 2478

2. is this template compatible with Joomla 4.

-Srini
Attachments:
The administrator has disabled public write access.

Errors on website with the quick starter template 1 month 2 weeks ago #31278

  • lousyfool
  • lousyfool's Avatar
  • Offline
  • Senior Member
  • Posts: 64
  • Thank you received: 4
  • Karma: 0
JD Guerilla is a pretty old template (last update November 2018), and seemingly not compatible with anything "modern".

1. These notices are indicating that you are running under PHP 7.4 or greater, but the template's underlying framework is still only compatible with 7.3 only.
What you can do:
- If everything is working as expected, ignore it and set Joomla's error reporting to "none". After all, it's only notices (not errors), so there's no reason to worry if everything is working.
- Or switch to PHP 7.3, if you can.
- Or try to update Helix 3 to its latest version. Just be careful to stick with Helix 3, not "Ultimate" or else.)

2. No. And, realistically, it will never be made to work with J!4.

If you need professional and affordable help due to a lack of experience or in-depth knowledge of web development etc, including Joomla, config, structure & design, customisations or avoidance/fixing of errors: contact me at This email address is being protected from spambots. You need JavaScript enabled to view it. (English or German)
The administrator has disabled public write access.

Errors on website with the quick starter template 1 month 2 weeks ago #31282

I just bought the template in September, do you think I can get a refund.
None of the pages are working so I don't think I can use this template at all.

-Srini
The administrator has disabled public write access.

Errors on website with the quick starter template 1 month 2 weeks ago #31284

  • lousyfool
  • lousyfool's Avatar
  • Offline
  • Senior Member
  • Posts: 64
  • Thank you received: 4
  • Karma: 0
Given the recent history here in the forum, not sure if, when or how JD support will reply here, but you could try contacting them here anyway.

If you need professional and affordable help due to a lack of experience or in-depth knowledge of web development etc, including Joomla, config, structure & design, customisations or avoidance/fixing of errors: contact me at This email address is being protected from spambots. You need JavaScript enabled to view it. (English or German)
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.346 seconds
Cron Job Starts