fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template.

Updating AcyMailing Starter Component version 6.14.1 to version 6.19.0 breaks the Astroid framework For JD Paris 1 year 1 month ago #26623

  • Ethlaegil
  • Ethlaegil's Avatar
  • Offline
  • New Member
  • Posts: 17
  • Thank you received: 1
  • Karma: 0
In the meanwhile as an ugly workaround we can rename error.php in the root of the template, so the standard Joomla! error page will show up at 404 error.
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 1 month ago #26737

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Johanv74 wrote:
Hi There,

Can you please help me to configure a working 404 page?
When I type a worng URL, I got an message: Please install and activate Astroid Framework in order to use this template.
Installed version Astroid: 2.4.7.
Template version: 1.2
URL Website: nw.vandervelde-web.nl
This wrong URL: nw.vandervelde-web.nl/jooml must give me a 404 warning.
Joomla version: 3.9.22
Error reportiung: Default setting
Updates: no updates available.

See 3 attached print screens for more information
Hi Johan,

Sorry for all the delay, the solution to this problem is renaming the htaccess.txt file to .htaccess then even with Modern Routing enabled and your URL rewriting is also set to Yes the error page will work correctly.

Let us know if this helped.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
The following user(s) said Thank You: Johanv74

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 4 weeks ago #26779

  • Johanv74
  • Johanv74's Avatar
  • Offline
  • Junior Member
  • Posts: 25
  • Karma: 0
Hello Nishtha,

htaccess was already renamed and URL rewriting is working.
I configured modern routing (for articles).
But i still got the message :-(.
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 3 weeks ago #26844

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Johanv74 wrote:
Hello Nishtha,

htaccess was already renamed and URL rewriting is working.
I configured modern routing (for articles).
But i still got the message :-(.

Hi Johan,

I had recreated your issue completely and then only suggested the same. I have enabled Modern Routing for the Articles and URL Rewriting for me the pages work absolutely fine(www.screencast.com/t/nHBqdgSRwR)

Did you try clearing all the caches and everything?

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 3 weeks ago #26901

  • Johanv74
  • Johanv74's Avatar
  • Offline
  • Junior Member
  • Posts: 25
  • Karma: 0
Hi Nishtha,

Sorry for my late reaction.
I created a new error.php and redirected it to the 404 article id (in my case id 232).

This is the only code in the error.php
Code:
<?php
defined('_JEXEC') or die;
if (($this->error->getCode()) == '404') {
header('Location: /index.php?option=com_content&view=article&id=232');
exit;}
?>

This is working for now, but not the way I want. Because you will see the url:
nw.vandervelde-web.nl/index.php?option=c...&view=article&id=232

Because I created an artible 404 including ad hidden menu item to this article I expect that I can use and see the url
nw.vandervelde-web.nl/404/ with the article instead of the url nw.vandervelde-web.nl/index.php?option=c...&view=article&id=232

To do the actions you show me in your video:
I reset the situation to before that i creating an new error.php.
I renamed the working bad solution to the error.php from the Astroid JD Paris template.

The options are set correctly. Zie print screen.
htaccess.txt recreated, cached cleared in Joomla and Browser.

I got the original error: Please install and activate Astroid Framework in order to use this template.

I you want i can create an account for you.
If Ok to wich e-mail adres can i sent the acount information?

Then you are able to test is by yourself on my site.

Thanks in advance also for your patience.
Attachments:
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 2 weeks ago #27006

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Johanv74 wrote:
Hi Nishtha,

Sorry for my late reaction.
I created a new error.php and redirected it to the 404 article id (in my case id 232).

This is the only code in the error.php
Code:
<?php
defined('_JEXEC') or die;
if (($this->error->getCode()) == '404') {
header('Location: /index.php?option=com_content&view=article&id=232');
exit;}
?>

This is working for now, but not the way I want. Because you will see the url:
nw.vandervelde-web.nl/index.php?option=c...&view=article&id=232

Because I created an artible 404 including ad hidden menu item to this article I expect that I can use and see the url
nw.vandervelde-web.nl/404/ with the article instead of the url nw.vandervelde-web.nl/index.php?option=c...&view=article&id=232

To do the actions you show me in your video:
I reset the situation to before that i creating an new error.php.
I renamed the working bad solution to the error.php from the Astroid JD Paris template.

The options are set correctly. Zie print screen.
htaccess.txt recreated, cached cleared in Joomla and Browser.

I got the original error: Please install and activate Astroid Framework in order to use this template.

I you want i can create an account for you.
If Ok to wich e-mail adres can i sent the acount information?

Then you are able to test is by yourself on my site.

Thanks in advance also for your patience.

Hey Johan,

Sorry for the delayed reply! I think it would be better if you can share us your backend login details along with this forum link which I can share with the developer so he can provide you the solution soon.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 2 weeks ago #27168

  • Johanv74
  • Johanv74's Avatar
  • Offline
  • Junior Member
  • Posts: 25
  • Karma: 0
Hello Nishtha,

Ofcourse I can create an account, but it seems not a good idea to post it here ;-).
Can you provide me an e-mail adres? Or you can sent it to: This email address is being protected from spambots. You need JavaScript enabled to view it..

Thank you in advance!

Kind regards

Johan
Last Edit: 1 year 2 weeks ago by Johanv74.
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 1 week ago #27186

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Hey Johan,

I guess this time we have now managed to fix the issue here. Can you please install this dev version on your test site and confirm the same.

Don't forget to take a backup just in case you lose any of your content.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
The following user(s) said Thank You: Johanv74

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 1 week ago #27226

  • Johanv74
  • Johanv74's Avatar
  • Offline
  • Junior Member
  • Posts: 25
  • Karma: 0
Hi Nishtha,

I installed the dev version, but this is an other template.
It is de Astroid framework template and not the JD Paris template.

But for this test, I changed the standard template from JD Paris to template One Default, and i Got a 404 page, but the image is not working (its a detail). When I changed the default template to Zero Default i got an text based 404 page.

Dee attached print screens.
Sow this is working, now you can change it for the JD Paris template (I gues).

I you want I can and will test it for you als wel for the JD Paris Dev version, when the error is fixed.
Thanks for your help and patience!

Kind Regards from the Netherlands!

Johan van der Velde
Last Edit: 1 year 1 week ago by Johanv74.
The administrator has disabled public write access.

JD_Paris 404 page not working. Message: Please install and activate Astroid Framework in order to use this template. 1 year 4 weeks ago #26782

  • Ethlaegil
  • Ethlaegil's Avatar
  • Offline
  • New Member
  • Posts: 17
  • Thank you received: 1
  • Karma: 0
Hello Nishtha,

htaccess.txt was already renamed in .htaccess and SEF is working correctly. With modern routing (without IDs in URL) the error message still appears at status 404!. As an ugly workaround I renamed error.php in error.php.kaputt! So right now, the standard Joomla! Error Page comes in! Have for example a look at www.kunstbauten.de/error
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.532 seconds
Cron Job Starts