fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: (SOLVED) Error with upgrade

Error with upgrade 10 months 1 day ago #29125

  • quasarti
  • quasarti's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi, I'm using JD Paris as template in my website (in Joomla), and when I've tried to upgrade Astroid Framework 2.4.1 or 2.5.0 (with Joomla updater) appears an error in my backend: " Class 'Astroid\Helper\Overrides' not found" and other error in the frontend as the attachment. I've tried to upgrade the template before or after the upgrade of framework, but still getting an error.

The administrator has disabled public write access.

Error with upgrade 10 months 1 day ago #29129

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Hi,

The first thing I would suggest you is refer to the template's changelog and delete the files mentioned there.

Secondly Astroid has been updated to 2.5.2 please update to the correct version.
Also don't forget to clear all the cache and keep a backup just in case

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Error with upgrade 9 months 4 weeks ago #29176

  • quasarti
  • quasarti's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi! Thanks for your reply.
I've tried to upgrade to 2.5.2 and apears the same error:
"Class 'Astroid\Helper\Overrides' not found"
Then I've delete every folder and file from changelog, I've cleared cache from Joomla and browser, but nothing changes.
Exactly the same error.
I made a backup before update.
The administrator has disabled public write access.

Error with upgrade 9 months 4 weeks ago #29204

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Hello,

JD Paris is not compatible with v2.5.2 but we are working on it.
For the moment. Please downgrade the Framework version from v2.5.2 to v2.4.1. Here is the link.

github.com/joomdev/Astroid-Framework/rel...framework-v2.4.1.zip


Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Error with upgrade 9 months 4 weeks ago #29212

  • quasarti
  • quasarti's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
I've tried before upgrading to 2.4.0 and 2.4.1, but with no success.
No errors while upgrading, but the website has the same error
The administrator has disabled public write access.

Error with upgrade 9 months 4 weeks ago #29216

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
You sure have deleted those files mentioned in the changelog?
What was the last version where it was working fine?

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Error with upgrade 9 months 4 weeks ago #29221

  • quasarti
  • quasarti's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Yes, in this case, I'm upgrading from 2.3.0 to 2.4.0 and I've deleted tags.php file and clear cache, but nothing changes.
The administrator has disabled public write access.

Error with upgrade 9 months 3 weeks ago #29233

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Did you only delete the tags.php file?

When updating from Astroid 2.3.0 to Astroid 2.4.1 you are required to delete the following:

1. Remove options & frontend folder from template. Path: jd_paris
2. Remove astroid & bootstrap folder from scss. Path: jd_paris/scss
3. Remove jui, vendor folder from js folder. Path: jd_paris/js
4. Remove script.js file from js folder. Path: jd_paris/js

Make sure you have deleted the above files and folders too.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
Last Edit: 9 months 3 weeks ago by nishtha.
The administrator has disabled public write access.

Error with upgrade 9 months 3 weeks ago #29266

  • quasarti
  • quasarti's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi, yes, I've deleted just tags.php, cause is the only file that the changelog mentions for 2.4.1: www.joomdev.com/astroid/changelog

Then I've deleted the folders and files that you mentioned, but it's worse than before:
The administrator has disabled public write access.

Error with upgrade 9 months 3 weeks ago #29267

  • quasarti
  • quasarti's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Sorry, it's my fault. I've looking the changelog of framework, and in the template changelog it's mentioned as you said (the only exception is that options folder doesn't exists).
But the website still getting errors, now the all text, menu and all bootstrap code it's hidden. (If I look the source code, it exists)
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: chandandeep
Time to create page: 0.570 seconds
Cron Job Starts