fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: error

error 3 years 5 months ago #10147

  • hatechsolutions
  • hatechsolutions's Avatar
  • Offline
  • Elite Member
  • Posts: 188
  • Thank you received: 1
  • Karma: 0
Please the attached error occur during the process of uploading a Joomla website. Each time i try to import my database from localhost (my pc) to web host the error keeping coming and i have tried several time. Could it be the template problem, i have you several of your template before and with no problem. Any Solutions to the rescue


The administrator has disabled public write access.

error 3 years 5 months ago #10149

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Hello,

This is Akeeba Backup problem, not a template problem. So please update the Akeeba Backup component on Local then take a site backup and upload on the server. Hopefully, it will be work.

Thanks.
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
The following user(s) said Thank You: hatechsolutions

error 3 years 5 months ago #10150

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4490
  • Thank you received: 647
  • Karma: 116
Hello,

The problem is the different version of Mysql on your localhost & online server.

Your localhost is using mysql 5.7+ but on the server you have mysql 5.6 or below.

You can just skip this table from your sql backup and rest will go fine and then just reinstall akeeba backup once the installation is done.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
Last Edit: 3 years 5 months ago by admin.
The administrator has disabled public write access.

error 3 years 5 months ago #10152

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4490
  • Thank you received: 647
  • Karma: 116
Alternatively,

You can change the query from;
CREATE TABLE IF NOT EXISTS `#__akeeba_common` (
	`key` varchar(192) COLLATE utf8mb4_unicode_ci NOT NULL,
	`value` longtext COLLATE utf8mb4_unicode_ci NOT NULL,
	PRIMARY KEY (`key`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;

to:
CREATE TABLE IF NOT EXISTS `#__akeeba_common` (
	`key` varchar(190) NOT NULL,
	`value` longtext NOT NULL,
	PRIMARY KEY (`key`)
) DEFAULT COLLATE utf8_general_ci CHARSET=utf8;
and that will fix the issue.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.549 seconds
Cron Job Starts