fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: InvalidArgumentException

InvalidArgumentException 2 years 8 months ago #12893

  • MarkV
  • MarkV's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Hi, i am using your extension 1.2 on a up to date Joomla 3.9.4 site. The form used to work but now it gives an error while submitting, strangely *only* in Edge browser:
Something went wrong! Please try again.
When I disabled AJAX i get the following:
InvalidArgumentException: Please specify a valid response format, other than that of HTML, such as json, raw, debug, etc.
Disabling Captcha doesnt make any difference.
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #12895

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Hey Mark,

The form is working fine on my end both on Edge browser and Internet Explorer, with or without Captcha.

Can you tell me the response of the form when you submit?
You can find the response in the network tab and look for an XHR/Ajax Request.
Post the response here so I can help.

Thanks,
Akash
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #12932

  • MarkV
  • MarkV's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Hi Akash, thank you for your reply. I don't understand were i can find the network tab you are talking about? Can you point me into the right direction?

Thanks, Mark
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #12933

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Mark,

Right click on the page (With the JD Simple Contact Form) > click Inspect > click on Network Tab.

And then submit the form, you'll see an XHR Request when you submit.

After that,
Click on Response tab. That response is what I want to see.

Let me know the response here.

Thanks,
Akash
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #12947

  • MarkV
  • MarkV's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Thanks for the instructions. I get 5 results, 3 of them are Captcha related and give 200 (so ok i presume). The other 2 are as follows:

Name Protocol Method Result Content type Received Time Initiator
www.elpgroep.nl/index.php?option=com_aja...on&method=submitForm HTTP/1.0 POST 303 text/html 0 B 267,53 ms XMLHttpRequest
www.elpgroep.nl/component/ajax/ HTTP/1.0 GET 404 text/html 204,55 ms XMLHttpRequest

I hope you can do something with this information.
Thanks in advance!
Last Edit: 2 years 8 months ago by MarkV.
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #13005

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4490
  • Thank you received: 647
  • Karma: 116
Hello,

I tried the submission on the following page and it worked just fine.
www.elpgroep.nl/aanmelden

Can't see anything wrong. Did you solved it?
Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #13028

  • MarkV
  • MarkV's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Hi Chetan, thanks for testing. Which browser did you use? The problem still occurs but only when using IE or Edge...
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #13050

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4490
  • Thank you received: 647
  • Karma: 116
I do see it. My bad. I ignored the initial code and tested it in chrome only.

We are working on a fix.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

InvalidArgumentException 2 years 8 months ago #13131

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Hello Mark,

Thank you for your patience.
The form is still working fine on our system on both Edge and Internet Explorer.

I am assuming that you're not running the latest version of JD Simple Contact Form.
We've rolled out some more updates and improvements and will be updating the extension on our site soon.
Until then, download the updated JD Simple Contact Form and install.

Do let me know, how it goes. :)

Thanks,
Akash
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
Last Edit: 2 years 8 months ago by akash. Reason: Replaced Broken Link.
The administrator has disabled public write access.

InvalidArgumentException 2 years 7 months ago #13482

  • MarkV
  • MarkV's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Hi Akash,
I just updated the plugin to version 1.3 and still the same problem :(
I did notice something different: only the field 'achternaam' and 'e-mailadres' are obligated. For testing purposes i filled in the form many times, so Edge is helping me by proposing a already filled in mailadres when i want to fill in that field. If i select that one *ALL* the empty fields are filled with my mailadres?!
I hope this helps, if you want i can setup a login for you so you can look in the backend of the website itself.
Thanks so far!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: akash, chandandeep
Time to create page: 0.448 seconds
Cron Job Starts